ICS-CERT: Ecava IntegraXor Path Traversal Vulnerability

Monday, March 26, 2012

Infosec Island Admin

7fef78c47060974e0b8392e305f0daf0

Independent researchers Billy Rios and Terry McCorkle have identified a Path Traversal vulnerability in the Ecava IntegraXor application. Ecava has produced an update that mitigates this vulnerability. The researchers have validated that the patch fixes this vulnerability.

According to Ecava, the following products are affected:

• IntegraXor versions older than Version 3.71.4200

IMPACT

Successful exploitation of this vulnerability may result in file manipulation or arbitrary code execution. Impact to individual organizations depends on many factors that are unique to each organization. ICS-CERT recommends that organizations evaluate the impact of this vulnerability based on their operational environment, architecture, and product implementation.

BACKGROUND

Ecava Sdn Bhd is a Malaysia-based software development company that provides the IntegraXor SCADA product. Ecava specializes in factory and process automation solutions.

IntegraXor is a suite of tools used to create and run a web-based human-machine interface for a SCADA system. IntegraXor is currently used in several areas of process control in 38 countries with the largest installation based in the United Kingdom, United States, Australia, Poland, Canada, and Estonia.

VULNERABILITY OVERVIEW

A path traversal vulnerability can occur when a specially crafted HTML document is opened on the Ecava IntegraXor server. Successful exploitation could allow file manipulation or arbitrary code execution.

This vulnerability is only exploitable while using Internet Explorer due to the proprietary Active X component. No other web browsers are affected by this vulnerability. CVE-2012-0246 has been assigned to this vulnerability. A CVSS V2 base score of 4.3 has also been assigned.

EXPLOITABILITY: This vulnerability is remotely exploitable.

EXISTENCE OF EXPLOIT: No known public exploits specifically target this vulnerability.

DIFFICULTY: Crafting a working exploit for this vulnerability requires a medium skill level. Social engineering is required to convince the user to accept the malformed HTML file.

Ecava recommends users to download and install update from their website:

The full ICS-CERT advisory can be found here:

Source:  http://www.us-cert.gov/control_systems/pdf/ICSA-12-083-01.pdf

Possibly Related Articles:
11601
SCADA
Industrial Control Systems
SCADA Social Engineering Vulnerabilities Exploits Infrastructure Advisory ICS-CERT Industrial Control Systems Ecava IntegraXor Path Traversal vulnerability
Post Rating I Like this!
The views expressed in this post are the opinions of the Infosec Island member that posted this content. Infosec Island is not responsible for the content or messaging of this post.

Unauthorized reproduction of this article (in part or in whole) is prohibited without the express written permission of Infosec Island and the Infosec Island member that posted this content--this includes using our RSS feed for any purpose other than personal use.